| Age | Commit message (Collapse) | Author | |
|---|---|---|---|
| 2015-09-22 | Merge branch 'link' into development | Eliot Whalan | |
| 2015-09-21 | Clean up HTML response construct, uppercase UTF-8 | WubTheCaptain | |
| IANA has registered UTF-8 as uppercase, hyphenated. The RFC concerning UTF-8, RFC 3629 also uses this grammar. RFC 2231 says the Content-Type charset value should be: charset := <registered character set name> RFC 5987 further emphasizes this: charset = "UTF-8" / "ISO-8859-1" / mime-charset Therefore lowercase "utf-8" in Content-Type responses is technically incorrect, but case-insensitive according to RFC 2616. Thanks to pantsucat for researching this with me. | |||
| 2015-09-21 | Remove dead and unmaintained tools | pantsucat | |
| 2015-09-20 | Change README.md contact email to a mailto: link | WubTheCaptain | |
| 2015-09-20 | Update links to correct URLs | pantsucat | |
| 2015-09-20 | Merge branch 'updatesql' into development | WubTheCaptain | |
| Merging this feature branch removes more moe code. | |||
| 2015-09-20 | Remove moe panel tables from core database schema | WubTheCaptain | |
| Accounts, invites and reports are not used in the core. These will be moved to pomf-moe repository. You don't need it anymore. While the change of `orginalname` to `originalname` is good to mention, it is better served in the documentantion for those who are upgrading instead of laying around useless here in this code repository. OK pantsucat | |||
| 2015-09-20 | Give update.sql some dos2unix(1) treatment | WubTheCaptain | |
| 2015-09-20 | Revert "Spelling error of the century" | WubTheCaptain | |
| You don't attempt to rename "A" to "A" in the database. Doing so breaks the patch. Restore the intended functionality "A" to "B". You also shouldn't be using Windows newlines. This reverts commit aa61832a73bac8e1045b70a887e5bee1839599d1. | |||
| 2015-09-20 | Fix limf contact URL | pantsucat | |
| 2015-09-20 | Merge branch 'license' into development | pantsucat | |
| 2015-09-20 | Add download link to gyazowin binary | pantsucat | |
| 2015-09-19 | Update LICENSE authors and years | WubTheCaptain | |
| 2015-09-19 | Change Git URL to self-hosted pantsu/pomf.git | WubTheCaptain | |
| 2015-09-19 | Remove moe panel from core | pantsucat | |
| The moe panel is more of an extension of the core, but not necessary for Pomf's functionality. The code also suffers from bad practices and it's more of a prototype. The panel is also mostly unmaintained by its author. This code will be in a seperate Git repository called pomf-moe from now on. | |||
| 2015-09-19 | Replace github urls with self-hosted Git | pantsucat | |
| 2015-09-19 | Remove line about moe | pantsucat | |
| 2015-09-19 | Remove moe panel from core | pantsucat | |
| The moe panel is more of an extension of the core, but not necessary for Pomf's functionality. The code also suffers from bad practices and it's more of a prototype. The panel is also mostly unmaintained by its author. This code will be in a seperate Git repository called pomf-moe from now on. | |||
| 2015-09-19 | Merge remote-tracking branch 'origin/giturl' into development | pantsucat | |
| 2015-09-19 | Replace github urls with self-hosted Git | pantsucat | |
| 2015-09-19 | Change Git clone URL to self-hosted Git | WubTheCaptain | |
| 2015-09-19 | Decode … correctly when the file is too big | WubTheCaptain | |
| 2015-09-19 | Refactor banner for improved readability | pantsucat | |
| 2015-09-19 | Enable 'screwIE8' option for UglifyJS task | WubTheCaptain | |
| Considering how IE11 too has difficulties working right now, there's no interest to support broken browsers. OK pantsucat | |||
| 2015-09-19 | Add LibreJS compatibility | pantsucat | |
| 2015-09-19 | Fix spelling of 'Ropa Interior' | pantsucat | |
| 2015-09-19 | Fix README.md outline | WubTheCaptain | |
| 2015-09-19 | Fix whitespace and restore PSR-2 style | WubTheCaptain | |
| 2015-09-18 | Change sharex setting url | pantsucat | |
| 2015-09-18 | Fix url generation bug | pantsucat | |
| 2015-09-18 | Revert ShareX / URL change commits | WubTheCaptain | |
| These commits are ShareX issues, not Pomf issues. Allowing these commits to be in the source reduces maintainability. This reverts commits bbcffe8d745937677352edf25e6a250ca8fd507b, 943e7e62a8ca814d47168bcebf2cc92dbce9a45a and partially 1411bce1dc13bf6fea66b5899ba29d50d5c53bb0. | |||
| 2015-09-18 | Remove unnecessary paragraphs | pantsucat | |
| 2015-09-18 | Add dist.zip to gitignore | pantsucat | |
| 2015-09-18 | Remove dist.zip | pantsucat | |
| Add dist.zip to gitignore | |||
| 2015-09-18 | Fix no html output on upload.php | pantsucat | |
| 2015-09-18 | Add text response class | pantsucat | |
| 2015-09-18 | Fixed minor typo | pantsucat | |
| 2015-09-18 | Add more translations to catalan | pantsucat | |
| 2015-09-18 | Fix link error | pantsucat | |
| 2015-09-18 | Fix html typo | pantsucat | |
| 2015-09-18 | Fix url links | pantsucat | |
| 2015-09-18 | Add links to updated and working scripts and tools | pantsucat | |
| 2015-09-18 | Start translation of pages to catalan | pantsucat | |
| 2015-09-17 | Fix url generation bug | pantsucat | |
| 2015-09-17 | Add html response class | pantsucat | |
| 2015-09-17 | Add link to JS free version | pantsucat | |
| 2015-09-17 | Fix to work with sharex | pantsucat | |
| 2015-09-17 | Add a version of the site without JavaScript | pantsucat | |
| 2015-09-16 | Remove poorly worded line from faq | pantsucat | |
| 2015-09-16 | Add email link to faq | pantsucat | |
