| Age | Commit message (Collapse) | Author |
|
|
|
|
|
|
|
Fenced code blocks are not part of the original markdown standard, thus
less portable. Even if fenced code blocks were used, they should specify
the code language with it.
Indented code blocks with 4 spaces are portable, which we prefer.
|
|
|
|
|
|
These files are non-free and can no longer be distributed with source
releases.
No free replacements are available. I have not attempted to reach out
the authors of images concerned.
- img/10.png: tisenomati,
http://www.pixiv.net/member_illust.php?mode=big&illust_id=9984708
- img/2.png: https://danbooru.donmai.us/posts/1011708 ->
http://haruka.saiin.net/~gyroscope/data/img/2011100201.jpg
- img/3.png: Luminous Flux,
http://www.pixiv.net/member_illust.php?mode=medium&illust_id=33001785
- img/4.png: Unclear origin. http://www.99comic.com/comics/7208o152458/
- img/5.png: Unclear origin. http://www.taringa.net/SonicIdol/mi/qyLSd
- img/6.png: Unclear origin.
- img/7.png: Spanuel,
http://spanuel.deviantart.com/art/Akiyama-Mio-vector-trace-429724879
- img/8.png: Kimi Ni Todoke 57 manga / Mango Scans
- img/9.png: https://danbooru.donmai.us/posts/459541 /
http://e-shuushuu.net/image/165818/ -> pixiv/ura-kata, dead origin
link at
http://www.pixiv.net/member_illust.php?mode=medium&illust_id=4418425
These files may have to be filtered later from Git history or an orphan
branch created from this commit forward to satisfy copyright.
|
|
|
|
|
|
|
|
|
|
|
|
Development at github has stopped and has been moved entirely over to
self hosted gogs server.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
GitFlow is considered harmful. There's some ugly history in master
branch which was essentially rewritten in the development branch.
This merges master into development with "ours" strategy, to keep clean
path of pulling from master.
Essentially, the development branch is now the new master.
|
|
|
|
|
|
IANA has registered UTF-8 as uppercase, hyphenated. The RFC concerning
UTF-8, RFC 3629 also uses this grammar.
RFC 2231 says the Content-Type charset value should be:
charset := <registered character set name>
RFC 5987 further emphasizes this:
charset = "UTF-8" / "ISO-8859-1" / mime-charset
Therefore lowercase "utf-8" in Content-Type responses is technically
incorrect, but case-insensitive according to RFC 2616.
Thanks to pantsucat for researching this with me.
|
|
|
|
|
|
This code doesn't seem to be in use nor important. There is no good
reason why this was left in here. Because it's not been in use for so
long and nobody has an issue with it, let's just remove it.
|
|
|
|
Adds curly braces and semicolons. Also change indentation to two spaces.
|
|
It should not be fatal to fail the build process if there's a syntax
error somewhere. Users don't need to care about that too much, only
developers should.
|
|
There's no sense to test the Gruntfile at this time, because it will
always fail to module.exports which works as intended.
|
|
This creates consistency with the project's style.
|
|
This should also fix the syntax, which fixes a build failure.
|
|
|
|
|
|
Merging this feature branch removes more moe code.
|
|
Accounts, invites and reports are not used in the core. These will be
moved to pomf-moe repository. You don't need it anymore.
While the change of `orginalname` to `originalname` is good to mention,
it is better served in the documentantion for those who are upgrading
instead of laying around useless here in this code repository.
OK pantsucat
|
|
|
|
You don't attempt to rename "A" to "A" in the database. Doing so breaks
the patch. Restore the intended functionality "A" to "B".
You also shouldn't be using Windows newlines.
This reverts commit aa61832a73bac8e1045b70a887e5bee1839599d1.
|
|
|
|
|
|
|
|
|
|
String concatenation is used because line terminating characters are not
allowed in the ECMAScript spec. Certain style guides such as Airbnb also
endorse using string concatenation.
|
|
Both Google and Node.js style guides prefer the use of ' over ". Much of
the rest of this code also uses singlequotes, so this brings the rest of
it to same level of consistency.
|
|
|