summaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2015-09-26Rename ca.swig as indexca.swigJuuso Lapinlampi
ca.swig is confusing and difficult to find. This commit creates consistency with other pages until someone more knowledgeable person tells me how to sort these to /pages/ca/ with Gruntfile.
2015-09-25Bump grunt-contrib-htmlmin version up to ^0.5.0Juuso Lapinlampi
This upgrades the htmlmin dependency to version 0.8.0. Unfortunately, upstream author does not maintain the CHANGELOG file.
2015-09-25Merge branch 'add-catalan-translation'Juuso Lapinlampi
Catalan translation courtesy of Cupkle. Few patches added by wub@.
2015-09-25Remove Pantsu.cat from check_fileapica.swig authorsJuuso Lapinlampi
wub@ and ewhal@ no longer have any content in this file. It's been replaced.
2015-09-25Fix HTML lang attributes for Catalan translationJuuso Lapinlampi
2015-09-25Add full, more accurate Catalan translationCupkle
2015-09-24Remove unused UploadedFile class $crc32 propertyJuuso Lapinlampi
get_crc32() was removed in commit ea6a7a0194 and never in use in the code. It seems Eric forgot to remove this property.
2015-09-24Add extra whitespace for var uploadBtn in pomf.jsJuuso Lapinlampi
This is not how it appeared in the initial commit 1792788f5f, but personally I like it and style guides allow me to adjust the whitespace for these kind of variables. Improves readability.
2015-09-24Add an extra whitespace for rowUrl in pomf.jsJuuso Lapinlampi
Improves readability by indenting these variables to same level. Restores whitespace style like in initial commit 1792788f5f.
2015-09-24Replace ambiguous MIT license mentions with ExpatJuuso Lapinlampi
MIT has used many licenses for software. Calling this project to be available under a "MIT" license is misleading.
2015-09-24Remove "The MIT License (MIT)" line from LICENSEJuuso Lapinlampi
The line is reduntant and more confusing than helpful. It belongs to README. The original Expat license text doesn't include this line.
2015-09-24HTML-ify html_error() response with <p>Eliot Whalan
2015-09-24Rename txt_error() to text_error()Eliot Whalan
2015-09-24Fix indentation to 2 spaces.Eliot Whalan
2015-09-24Addition symbol prevented urls from being passedEliot Whalan
Fix bug introduced in 6c82d36307.
2015-09-24Merge remote-tracking branch 'origin/liberate-img'Eliot Whalan
Remove non-free images
2015-09-24Merge remote-tracking branch 'origin/copyright-headers'Eliot Whalan
2015-09-23Fix other.swig title from "FAQ" to "Other Services"Juuso Lapinlampi
2015-09-23Fix index page indentation from spaces to tabsJuuso Lapinlampi
Silly ewhal@, that's not how you indent pages. Fixes a code style violation introduced in commit 87014fa08f.
2015-09-23Add Expat copyright headers to pages (SWIG)Juuso Lapinlampi
2015-09-23Add cenci0 to contributors in LICENSE / package.jsonJuuso Lapinlampi
cenci0 has a lot of improved code in static/classes/Response.class.php and static/upload.php. This can be seen in commit 5b77a4eaab.
2015-09-23Add Expat copyright headers to PHP filesJuuso Lapinlampi
Interestingly, static/classes/UploadedFile.class.php is not licensed under Expat license. Because it was posted in PHP.net comments, I believe it's under the PHP license.
2015-09-23Add Expat copyright headers to JavaScript filesJuuso Lapinlampi
2015-09-23Add author email addresses to LICENSEJuuso Lapinlampi
2015-09-23Add Expat copyright header to css/pomf.cssJuuso Lapinlampi
2015-09-23Replace markdown backticks with four space indentsJuuso Lapinlampi
Fenced code blocks are not part of the original markdown standard, thus less portable. Even if fenced code blocks were used, they should specify the code language with it. Indented code blocks with 4 spaces are portable, which we prefer.
2015-09-23Add missing whitespace to check_fileapi (Firefox)Juuso Lapinlampi
2015-09-23Remove now-dead code for kawaii grill imagesJuuso Lapinlampi
2015-09-23Remove non-free kawaii imagesJuuso Lapinlampi
These files are non-free and can no longer be distributed with source releases. No free replacements are available. I have not attempted to reach out the authors of images concerned. - img/10.png: tisenomati, http://www.pixiv.net/member_illust.php?mode=big&illust_id=9984708 - img/2.png: https://danbooru.donmai.us/posts/1011708 -> http://haruka.saiin.net/~gyroscope/data/img/2011100201.jpg - img/3.png: Luminous Flux, http://www.pixiv.net/member_illust.php?mode=medium&illust_id=33001785 - img/4.png: Unclear origin. http://www.99comic.com/comics/7208o152458/ - img/5.png: Unclear origin. http://www.taringa.net/SonicIdol/mi/qyLSd - img/6.png: Unclear origin. - img/7.png: Spanuel, http://spanuel.deviantart.com/art/Akiyama-Mio-vector-trace-429724879 - img/8.png: Kimi Ni Todoke 57 manga / Mango Scans - img/9.png: https://danbooru.donmai.us/posts/459541 / http://e-shuushuu.net/image/165818/ -> pixiv/ura-kata, dead origin link at http://www.pixiv.net/member_illust.php?mode=medium&illust_id=4418425 These files may have to be filtered later from Git history or an orphan branch created from this commit forward to satisfy copyright.
2015-09-23Merge https://git.pantsu.cat/yrrah2/pomfEliot Whalan
2015-09-23Fix sharex config URLEliot Whalan
2015-09-23Add JS free version linkEliot Whalan
2015-09-23Add hidden service urlEliot Whalan
2015-09-23Add JS source location for LibreJSEliot Whalan
2015-09-23Replace github url with git.pantsu.catEliot Whalan
Development at github has stopped and has been moved entirely over to self hosted gogs server.
2015-09-23Increase max_upload_size to 128MiBEliot Whalan
2015-09-23Fix whitespace problemsEliot Whalan
2015-09-23Fix spelling mistakeEliot Whalan
2015-09-23Update package.json author, add contributorsEliot Whalan
2015-09-23Removed Todo sectionHarry H
2015-09-23Replace github links with git.pantsu.catEliot Whalan
2015-09-23Merge branch 'update-depends'Eliot Whalan
2015-09-23Update Gruntfile to work with updated dependenciesEliot Whalan
2015-09-23Update all dependencies to latest versionsEliot Whalan
2015-09-22Change MIT to expat license in GruntfileEliot Whalan
2015-09-22Add missing double quote in FAQEliot Whalan
2015-09-22Merge branch 'master' into developmentWubTheCaptain
GitFlow is considered harmful. There's some ugly history in master branch which was essentially rewritten in the development branch. This merges master into development with "ours" strategy, to keep clean path of pulling from master. Essentially, the development branch is now the new master.
2015-09-22Merge branch 'jshint' into developmentEliot Whalan
2015-09-22Merge branch 'link' into developmentEliot Whalan
2015-09-21Clean up HTML response construct, uppercase UTF-8WubTheCaptain
IANA has registered UTF-8 as uppercase, hyphenated. The RFC concerning UTF-8, RFC 3629 also uses this grammar. RFC 2231 says the Content-Type charset value should be: charset := <registered character set name> RFC 5987 further emphasizes this: charset = "UTF-8" / "ISO-8859-1" / mime-charset Therefore lowercase "utf-8" in Content-Type responses is technically incorrect, but case-insensitive according to RFC 2616. Thanks to pantsucat for researching this with me.