| Age | Commit message (Collapse) | Author |
|
|
|
|
|
|
|
|
|
GitFlow is considered harmful. There's some ugly history in master
branch which was essentially rewritten in the development branch.
This merges master into development with "ours" strategy, to keep clean
path of pulling from master.
Essentially, the development branch is now the new master.
|
|
|
|
|
|
IANA has registered UTF-8 as uppercase, hyphenated. The RFC concerning
UTF-8, RFC 3629 also uses this grammar.
RFC 2231 says the Content-Type charset value should be:
charset := <registered character set name>
RFC 5987 further emphasizes this:
charset = "UTF-8" / "ISO-8859-1" / mime-charset
Therefore lowercase "utf-8" in Content-Type responses is technically
incorrect, but case-insensitive according to RFC 2616.
Thanks to pantsucat for researching this with me.
|
|
|
|
|
|
This code doesn't seem to be in use nor important. There is no good
reason why this was left in here. Because it's not been in use for so
long and nobody has an issue with it, let's just remove it.
|
|
|
|
Adds curly braces and semicolons. Also change indentation to two spaces.
|
|
It should not be fatal to fail the build process if there's a syntax
error somewhere. Users don't need to care about that too much, only
developers should.
|
|
There's no sense to test the Gruntfile at this time, because it will
always fail to module.exports which works as intended.
|
|
This creates consistency with the project's style.
|
|
This should also fix the syntax, which fixes a build failure.
|
|
|
|
|
|
Merging this feature branch removes more moe code.
|
|
Accounts, invites and reports are not used in the core. These will be
moved to pomf-moe repository. You don't need it anymore.
While the change of `orginalname` to `originalname` is good to mention,
it is better served in the documentantion for those who are upgrading
instead of laying around useless here in this code repository.
OK pantsucat
|
|
|
|
You don't attempt to rename "A" to "A" in the database. Doing so breaks
the patch. Restore the intended functionality "A" to "B".
You also shouldn't be using Windows newlines.
This reverts commit aa61832a73bac8e1045b70a887e5bee1839599d1.
|
|
|
|
|
|
|
|
|
|
String concatenation is used because line terminating characters are not
allowed in the ECMAScript spec. Certain style guides such as Airbnb also
endorse using string concatenation.
|
|
Both Google and Node.js style guides prefer the use of ' over ". Much of
the rest of this code also uses singlequotes, so this brings the rest of
it to same level of consistency.
|
|
|
|
The npm style guide is bad. Don't use it! The lack of semicolons can
create very subtle bugs that are hard to debug.
This commit fixes about a hundred JSHint warnings.
|
|
|
|
This fixes another npm style guide idiom, which is "comma first".
|
|
|
|
Airbnb, Google, npm, Node.js and Idiomatic style guides suggest to use
two spaces for indentation. It seems to be the widely agreed consensus.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
The moe panel is more of an extension of the core, but not necessary for
Pomf's functionality. The code also suffers from bad practices and it's
more of a prototype. The panel is also mostly unmaintained by its
author.
This code will be in a seperate Git repository called pomf-moe from now
on.
|
|
|
|
|
|
The moe panel is more of an extension of the core, but not necessary for
Pomf's functionality. The code also suffers from bad practices and it's
more of a prototype. The panel is also mostly unmaintained by its
author.
This code will be in a seperate Git repository called pomf-moe from now
on.
|
|
|
|
|
|
|
|
|
|
|