summaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2015-09-23static/upload.php: Use strict comparison for $triesJuuso Lapinlampi
2015-09-23Fix other.swig title from "FAQ" to "Other Services"Juuso Lapinlampi
2015-09-23Fix index page indentation from spaces to tabsJuuso Lapinlampi
Silly ewhal@, that's not how you indent pages. Fixes a code style violation introduced in commit 87014fa08f.
2015-09-23Add Expat copyright headers to pages (SWIG)Juuso Lapinlampi
2015-09-23Add cenci0 to contributors in LICENSE / package.jsonJuuso Lapinlampi
cenci0 has a lot of improved code in static/classes/Response.class.php and static/upload.php. This can be seen in commit 5b77a4eaab.
2015-09-23Add Expat copyright headers to PHP filesJuuso Lapinlampi
Interestingly, static/classes/UploadedFile.class.php is not licensed under Expat license. Because it was posted in PHP.net comments, I believe it's under the PHP license.
2015-09-23Add Expat copyright headers to JavaScript filesJuuso Lapinlampi
2015-09-23Add author email addresses to LICENSEJuuso Lapinlampi
2015-09-23Add Expat copyright header to css/pomf.cssJuuso Lapinlampi
2015-09-23Replace markdown backticks with four space indentsJuuso Lapinlampi
Fenced code blocks are not part of the original markdown standard, thus less portable. Even if fenced code blocks were used, they should specify the code language with it. Indented code blocks with 4 spaces are portable, which we prefer.
2015-09-23Add missing whitespace to check_fileapi (Firefox)Juuso Lapinlampi
2015-09-23Remove now-dead code for kawaii grill imagesJuuso Lapinlampi
2015-09-23Remove non-free kawaii imagesJuuso Lapinlampi
These files are non-free and can no longer be distributed with source releases. No free replacements are available. I have not attempted to reach out the authors of images concerned. - img/10.png: tisenomati, http://www.pixiv.net/member_illust.php?mode=big&illust_id=9984708 - img/2.png: https://danbooru.donmai.us/posts/1011708 -> http://haruka.saiin.net/~gyroscope/data/img/2011100201.jpg - img/3.png: Luminous Flux, http://www.pixiv.net/member_illust.php?mode=medium&illust_id=33001785 - img/4.png: Unclear origin. http://www.99comic.com/comics/7208o152458/ - img/5.png: Unclear origin. http://www.taringa.net/SonicIdol/mi/qyLSd - img/6.png: Unclear origin. - img/7.png: Spanuel, http://spanuel.deviantart.com/art/Akiyama-Mio-vector-trace-429724879 - img/8.png: Kimi Ni Todoke 57 manga / Mango Scans - img/9.png: https://danbooru.donmai.us/posts/459541 / http://e-shuushuu.net/image/165818/ -> pixiv/ura-kata, dead origin link at http://www.pixiv.net/member_illust.php?mode=medium&illust_id=4418425 These files may have to be filtered later from Git history or an orphan branch created from this commit forward to satisfy copyright.
2015-09-23Merge https://git.pantsu.cat/yrrah2/pomfEliot Whalan
2015-09-23Fix sharex config URLEliot Whalan
2015-09-23Add JS free version linkEliot Whalan
2015-09-23Add hidden service urlEliot Whalan
2015-09-23Add JS source location for LibreJSEliot Whalan
2015-09-23Replace github url with git.pantsu.catEliot Whalan
Development at github has stopped and has been moved entirely over to self hosted gogs server.
2015-09-23Increase max_upload_size to 128MiBEliot Whalan
2015-09-23Fix whitespace problemsEliot Whalan
2015-09-23Fix spelling mistakeEliot Whalan
2015-09-23Update package.json author, add contributorsEliot Whalan
2015-09-23Removed Todo sectionHarry H
2015-09-23Replace github links with git.pantsu.catEliot Whalan
2015-09-23Merge branch 'update-depends'Eliot Whalan
2015-09-23Update Gruntfile to work with updated dependenciesEliot Whalan
2015-09-23Update all dependencies to latest versionsEliot Whalan
2015-09-22Change MIT to expat license in GruntfileEliot Whalan
2015-09-22Add missing double quote in FAQEliot Whalan
2015-09-22Merge branch 'master' into developmentWubTheCaptain
GitFlow is considered harmful. There's some ugly history in master branch which was essentially rewritten in the development branch. This merges master into development with "ours" strategy, to keep clean path of pulling from master. Essentially, the development branch is now the new master.
2015-09-22Merge branch 'jshint' into developmentEliot Whalan
2015-09-22Merge branch 'link' into developmentEliot Whalan
2015-09-21Clean up HTML response construct, uppercase UTF-8WubTheCaptain
IANA has registered UTF-8 as uppercase, hyphenated. The RFC concerning UTF-8, RFC 3629 also uses this grammar. RFC 2231 says the Content-Type charset value should be: charset := <registered character set name> RFC 5987 further emphasizes this: charset = "UTF-8" / "ISO-8859-1" / mime-charset Therefore lowercase "utf-8" in Content-Type responses is technically incorrect, but case-insensitive according to RFC 2616. Thanks to pantsucat for researching this with me.
2015-09-21Remove dead and unmaintained toolspantsucat
2015-09-20Change README.md contact email to a mailto: linkWubTheCaptain
2015-09-20Remove commented code about Mozilla's file inputWubTheCaptain
This code doesn't seem to be in use nor important. There is no good reason why this was left in here. Because it's not been in use for so long and nobody has an issue with it, let's just remove it.
2015-09-20Simplify multiple ifs to one if with OR conditionWubTheCaptain
2015-09-20Clean up cheesesteak.js and cabinet.js for JSHintWubTheCaptain
Adds curly braces and semicolons. Also change indentation to two spaces.
2015-09-20Move JSHint task away from default/dist to testWubTheCaptain
It should not be fatal to fail the build process if there's a syntax error somewhere. Users don't need to care about that too much, only developers should.
2015-09-20Remove Gruntfile from JSHint testingWubTheCaptain
There's no sense to test the Gruntfile at this time, because it will always fail to module.exports which works as intended.
2015-09-20Indent Gruntfile from tabs to two spacesWubTheCaptain
This creates consistency with the project's style.
2015-09-20Add undef: true check to Gruntfile's JSHint taskWubTheCaptain
This should also fix the syntax, which fixes a build failure.
2015-09-20Add all Javascript files to JSHint taskpantsucat
2015-09-20Update links to correct URLspantsucat
2015-09-20Merge branch 'updatesql' into developmentWubTheCaptain
Merging this feature branch removes more moe code.
2015-09-20Remove moe panel tables from core database schemaWubTheCaptain
Accounts, invites and reports are not used in the core. These will be moved to pomf-moe repository. You don't need it anymore. While the change of `orginalname` to `originalname` is good to mention, it is better served in the documentantion for those who are upgrading instead of laying around useless here in this code repository. OK pantsucat
2015-09-20Give update.sql some dos2unix(1) treatmentWubTheCaptain
2015-09-20Revert "Spelling error of the century"WubTheCaptain
You don't attempt to rename "A" to "A" in the database. Doing so breaks the patch. Restore the intended functionality "A" to "B". You also shouldn't be using Windows newlines. This reverts commit aa61832a73bac8e1045b70a887e5bee1839599d1.
2015-09-20Add JSHint headers to cabinet and cheesesteakWubTheCaptain