| Age | Commit message (Collapse) | Author | |
|---|---|---|---|
| 2015-09-23 | Add Expat copyright headers to pages (SWIG) | Juuso Lapinlampi | |
| 2015-09-23 | Add cenci0 to contributors in LICENSE / package.json | Juuso Lapinlampi | |
| cenci0 has a lot of improved code in static/classes/Response.class.php and static/upload.php. This can be seen in commit 5b77a4eaab. | |||
| 2015-09-23 | Add Expat copyright headers to PHP files | Juuso Lapinlampi | |
| Interestingly, static/classes/UploadedFile.class.php is not licensed under Expat license. Because it was posted in PHP.net comments, I believe it's under the PHP license. | |||
| 2015-09-23 | Add Expat copyright headers to JavaScript files | Juuso Lapinlampi | |
| 2015-09-23 | Add author email addresses to LICENSE | Juuso Lapinlampi | |
| 2015-09-23 | Add Expat copyright header to css/pomf.css | Juuso Lapinlampi | |
| 2015-09-23 | Replace markdown backticks with four space indents | Juuso Lapinlampi | |
| Fenced code blocks are not part of the original markdown standard, thus less portable. Even if fenced code blocks were used, they should specify the code language with it. Indented code blocks with 4 spaces are portable, which we prefer. | |||
| 2015-09-23 | Add missing whitespace to check_fileapi (Firefox) | Juuso Lapinlampi | |
| 2015-09-23 | Merge https://git.pantsu.cat/yrrah2/pomf | Eliot Whalan | |
| 2015-09-23 | Fix sharex config URL | Eliot Whalan | |
| 2015-09-23 | Add JS free version link | Eliot Whalan | |
| 2015-09-23 | Add hidden service url | Eliot Whalan | |
| 2015-09-23 | Add JS source location for LibreJS | Eliot Whalan | |
| 2015-09-23 | Replace github url with git.pantsu.cat | Eliot Whalan | |
| Development at github has stopped and has been moved entirely over to self hosted gogs server. | |||
| 2015-09-23 | Increase max_upload_size to 128MiB | Eliot Whalan | |
| 2015-09-23 | Fix whitespace problems | Eliot Whalan | |
| 2015-09-23 | Fix spelling mistake | Eliot Whalan | |
| 2015-09-23 | Update package.json author, add contributors | Eliot Whalan | |
| 2015-09-23 | Removed Todo section | Harry H | |
| 2015-09-23 | Replace github links with git.pantsu.cat | Eliot Whalan | |
| 2015-09-23 | Merge branch 'update-depends' | Eliot Whalan | |
| 2015-09-23 | Update Gruntfile to work with updated dependencies | Eliot Whalan | |
| 2015-09-23 | Update all dependencies to latest versions | Eliot Whalan | |
| 2015-09-22 | Change MIT to expat license in Gruntfile | Eliot Whalan | |
| 2015-09-22 | Add missing double quote in FAQ | Eliot Whalan | |
| 2015-09-22 | Merge branch 'master' into development | WubTheCaptain | |
| GitFlow is considered harmful. There's some ugly history in master branch which was essentially rewritten in the development branch. This merges master into development with "ours" strategy, to keep clean path of pulling from master. Essentially, the development branch is now the new master. | |||
| 2015-09-22 | Merge branch 'jshint' into development | Eliot Whalan | |
| 2015-09-22 | Merge branch 'link' into development | Eliot Whalan | |
| 2015-09-21 | Clean up HTML response construct, uppercase UTF-8 | WubTheCaptain | |
| IANA has registered UTF-8 as uppercase, hyphenated. The RFC concerning UTF-8, RFC 3629 also uses this grammar. RFC 2231 says the Content-Type charset value should be: charset := <registered character set name> RFC 5987 further emphasizes this: charset = "UTF-8" / "ISO-8859-1" / mime-charset Therefore lowercase "utf-8" in Content-Type responses is technically incorrect, but case-insensitive according to RFC 2616. Thanks to pantsucat for researching this with me. | |||
| 2015-09-21 | Remove dead and unmaintained tools | pantsucat | |
| 2015-09-20 | Change README.md contact email to a mailto: link | WubTheCaptain | |
| 2015-09-20 | Remove commented code about Mozilla's file input | WubTheCaptain | |
| This code doesn't seem to be in use nor important. There is no good reason why this was left in here. Because it's not been in use for so long and nobody has an issue with it, let's just remove it. | |||
| 2015-09-20 | Simplify multiple ifs to one if with OR condition | WubTheCaptain | |
| 2015-09-20 | Clean up cheesesteak.js and cabinet.js for JSHint | WubTheCaptain | |
| Adds curly braces and semicolons. Also change indentation to two spaces. | |||
| 2015-09-20 | Move JSHint task away from default/dist to test | WubTheCaptain | |
| It should not be fatal to fail the build process if there's a syntax error somewhere. Users don't need to care about that too much, only developers should. | |||
| 2015-09-20 | Remove Gruntfile from JSHint testing | WubTheCaptain | |
| There's no sense to test the Gruntfile at this time, because it will always fail to module.exports which works as intended. | |||
| 2015-09-20 | Indent Gruntfile from tabs to two spaces | WubTheCaptain | |
| This creates consistency with the project's style. | |||
| 2015-09-20 | Add undef: true check to Gruntfile's JSHint task | WubTheCaptain | |
| This should also fix the syntax, which fixes a build failure. | |||
| 2015-09-20 | Add all Javascript files to JSHint task | pantsucat | |
| 2015-09-20 | Update links to correct URLs | pantsucat | |
| 2015-09-20 | Merge branch 'updatesql' into development | WubTheCaptain | |
| Merging this feature branch removes more moe code. | |||
| 2015-09-20 | Remove moe panel tables from core database schema | WubTheCaptain | |
| Accounts, invites and reports are not used in the core. These will be moved to pomf-moe repository. You don't need it anymore. While the change of `orginalname` to `originalname` is good to mention, it is better served in the documentantion for those who are upgrading instead of laying around useless here in this code repository. OK pantsucat | |||
| 2015-09-20 | Give update.sql some dos2unix(1) treatment | WubTheCaptain | |
| 2015-09-20 | Revert "Spelling error of the century" | WubTheCaptain | |
| You don't attempt to rename "A" to "A" in the database. Doing so breaks the patch. Restore the intended functionality "A" to "B". You also shouldn't be using Windows newlines. This reverts commit aa61832a73bac8e1045b70a887e5bee1839599d1. | |||
| 2015-09-20 | Add JSHint headers to cabinet and cheesesteak | WubTheCaptain | |
| 2015-09-20 | Add jshint to grunt.registerTask | pantsucat | |
| 2015-09-20 | Remove extra comma in package.json | pantsucat | |
| 2015-09-20 | Add jshint grunt task and dependency | pantsucat | |
| 2015-09-20 | Wrap long lines to 80 characters in length | WubTheCaptain | |
| String concatenation is used because line terminating characters are not allowed in the ECMAScript spec. Certain style guides such as Airbnb also endorse using string concatenation. | |||
| 2015-09-20 | Use singlequotes | WubTheCaptain | |
| Both Google and Node.js style guides prefer the use of ' over ". Much of the rest of this code also uses singlequotes, so this brings the rest of it to same level of consistency. | |||
